Suchskript funktioniert, findet jedoch keine Ergebnisse (Support für das Suchscript)

Atrox, Thursday, 08.02.2024, 12:59 (vor 128 Tagen)

Hallo zusammen,

ich habe aktuell das Problem, dass bei einer meiner Webseiten das Suchskript, nachdem ich das Skript neu heruntergeladen und auf den Server (Hosting: Ionos) hochgeladen habe, keine Suchergebnisse mehr findet.

Es kommt immer nur bei den Suchergebnissen (suchen.php) die Überschrift "Sie Suchen nach >>[der gesuchte Begriff]<<". Vor ca. 1 Jahr ging das Suchskript noch mit den gleichen Einstellungen und der gleichen Ordnerstruktur. Trotzdem einmal die Frage:

Woran kann das liegen?

Meine Ordnerstruktur sieht folgenderweise aus:
/ZZZ/Webseite/:
- Hier liegen die index.html, suchen.php, kontakt.html, aktuelles.html, ...
- Außerdem liegt hier der Skript-Ordner "suchen" (umbenannt in "suchscript").

- Weiterhin gibt es noch einen Unterordner für Beiträge --> /ZZZ/Webseite/Beitraege/
- Darin sind nur .html-Seiten für die versch. Beiträge aufgeführt.

Wenn ich in der search_config.php die Parameter "$dirs" setzen will, was genau ist denn das "Stammverzeichnis"? Der Pfad der "search.php" (Skript) oder der "suchen.php"?

Vielen Dank vorab.

Eintrag gesperrt
903 Views
Avatar

Suchskript funktioniert, findet jedoch keine Ergebnisse

Fritz ⌂, Thursday, 08.02.2024, 13:12 (vor 128 Tagen) @ Atrox

- Außerdem liegt hier der Skript-Ordner "suchen" (umbenannt in "suchscript").

„Skript-Ordner“ - ist damit der Ordner gemeint, in dem u.a. die Dateien search.php, wdw_sucht.js usw. liegen?
Dieser Ordner muss „wdw_suche“ heißen. Bei der Neuinstallation wird „wdw_suche“ auch automatisch angelegt und mit den benötigten Dateien befüllt.

Eintrag gesperrt
1004 Views

Suchskript funktioniert, findet jedoch keine Ergebnisse

Atrox, Thursday, 08.02.2024, 13:23 (vor 128 Tagen) @ Fritz

Da die Formatierung nicht übernommen wurde, hier der Aufbau als Bild:

[image]

Eintrag gesperrt
1040 Views
Avatar

Suchskript funktioniert, findet jedoch keine Ergebnisse

Fritz ⌂, Thursday, 08.02.2024, 14:43 (vor 128 Tagen) @ Atrox

Das Verzeichnis /wdw_suche muss ein Unterverzeichnis von /Webseite sein, also an Stelle des Unterverzeichnisses /suchscript

Eintrag gesperrt
926 Views

Suchskript funktioniert, findet jedoch keine Ergebnisse

Atrox, Thursday, 08.02.2024, 14:52 (vor 128 Tagen) @ Fritz

Das Verzeichnis /wdw_suche muss ein Unterverzeichnis von /Webseite sein, also an Stelle des Unterverzeichnisses /suchscript

Vielen Dank! Das hat das Problem behoben!