Suchscript funktioniert nicht nach Umstellung auf PHP 8.2 (Support für das Suchscript)

Manfred @, Berlin, Sunday, 23.04.2023, 14:50 (vor 429 Tagen)

Hallo Fritz,
mit der Umstellung der PHP Version von 7 auf 8 funktioniert die Suche nur noch bis 'Sie suchen nach »abc«' und das war es. Mit 2 Buchstaben als Suchwort erhalte ich die Meldung es mit mindestens 3 Buchstaben zu suchen. Diese Meldung ist komplett als Webseite aufgebaut. Mit 3 Buchstaben --> Absturz.

Im Apache error.log finde ich dazu den folgenden Eintrag:

[Sun Apr 23 14:08:43.694178 2023] [mpm_prefork:notice] [pid 81978] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Sun Apr 23 14:08:43.694198 2023] [core:notice] [pid 81978] AH00094: Command line: '/usr/sbin/apache2'
[Sun Apr 23 14:38:41.943740 2023] [php:error] [pid 85979] [client 192.168.178.21:57926] PHP Fatal error: Uncaught TypeError: fwrite(): Argument #1 ($stream) must be of type resource, bool given in /home/manfred/projects/seniorenkantorei/public/wdw_suche/search.php(18) : eval()'d code:822\nStack trace:\n#0 /home/manfred/projects/seniorenkantorei/public/wdw_suche/search.php(18) : eval()'d code(822): fwrite()\n#1 /home/manfred/projects/seniorenkantorei/public/wdw_suche/search.php(18) : eval()'d code(863): schreiben()\n#2 /home/manfred/projects/seniorenkantorei/public/wdw_suche/search.php(18) : eval()'d code(872): ip_sperre()\n#3 /home/manfred/projects/seniorenkantorei/public/wdw_suche/search.php(18): eval()\n#4 /home/manfred/projects/seniorenkantorei/public/suchen.php(26): include('...')\n#5 {main}\n thrown in /home/manfred/projects/seniorenkantorei/public/wdw_suche/search.php(18) : eval()'d code on line 822, referer: http://192.168.178.46/suchen.php?q=abc

Ich habe z.Z. die letzte ladbare Scriptversion .37 im Einsatz. Die Version .38 wird nicht geladen.
Wo kann ich ansetzen, dass alles wieder so zufriedenstellend läuft wie bislang?
mit besten Grüßen Manfred

Eintrag gesperrt
1626 Views

gesamter Thread: